Knowledgebase:
Operazioni sull'archivio

L'archivio, assieme al database, in cui vengono conservati dati di programmazione e messa in onda, rappresentano il nucleo della propria emittente radiofonica.
Nello specifico l'archivio contiene tutte le informazioni associate agli elementi e ai brani necessari per la messa in onda della radio, assieme alle modalità e alle regole con le quali verranno riprodotti.

Creare un archivio

L’archivio dei file audio in Xautomation contiene tutto il materiale sonoro necessario alla messa in onda della radio.

Per creare un archivio:

  1. Nella barra dei menu fare clic su File > Aggiungi file audio.
  2. Nella finestra di dialogo visualizzata inserire un nome per l'archivio.
  3. Fare clic su OK.



    L'archivio viene salvato e automaticamente impostato come archivio predefinito. Ad ogni riavvio di Xautomation viene aperto automaticamente.

Salvare un archivio

Per salvare un archivio:

  1. Nella barra dei menu fare clic su File > Salva archivio.



Modificare l'archivio predefinito

Per modificare l'archivio predefinito:

  1. Nella barra dei menu fare clic su Modifica > Impostazioni.
  2. Posizionarsi nella scheda Avvio.
  3. Nel campo Nome archivio inserire l'archivio da rendere predefinito.
    Tramite il pulsante  sfogliare gli archivi creati e salvati.
  4. Dopo aver scelto l'archivio predefinito, fare clic su Modifica con unità Y: e fare clic su Applica.



Aprire un archivio

Se si desidera aprire un archivio differente da quello in uso:

  1. Fare clic su File > Chiudi archivio.
  2. Fare clic su Si per confermare l'operazione.
  3. Fare clic su File > Apri archivio.
  4. Scegliere l'archivio desiderato dalla lista e fare clic su Apri.



Aggiornare un archivio

Aggiornare l'archivio può essere utile per aggiornare l'interfaccia principale e per sincronizzare eventuali modifiche apportate all'archivio da una postazione secondaria.
Xautomation può essere installato su una o più postazioni per svolgere tutto il lavoro di inserimento brani, editing e modifica del palinsesto. Queste postazioni sono collegate in rete e condividono lo stesso percorso dell'unità Y: e dell'unità Z: e quindi gli stessi file di archivio e cartelle, caricano lo stesso archivio e fanno riferimento allo stesso database.
La postazione principale dove avviene la messa in onda deve avere l'opzione Imposta come PC di messa in onda abilitata. Questi settaggi possono essere modificati da Modifica > Impostazioni > Avvio.

Per aggiornare l'archivio se si sono effettuate delle modifiche, dalla postazione di messa in onda o da postazioni secondarie:

  1. Nella barra dei menu fare clic su File > Aggiornamento > Aggiorna tutti gli archivi.
  2. Fare clic su Si per confermare l'operazione.

IMPORTANTE:
Non salvare mai l'archivio dalla postazione di messa in onda o dalle altre postazioni secondarie subito dopo aver effettuato il salvataggio dalla postazione di modifica. In questo modo le modifiche all'archivio salvate dalla postazione vengono sovrascritte e perse. Se ciò dovesse accadere, è possibile salvare di nuovo l’archivio dalla postazione secondaria di modifica, se Xautomation non è stato ancora chiuso.
La regola da seguire lavorando con più postazioni è la seguente: 

  1. La postazione che effettua la modifica salva l'archivio.
  2. Tutte le altre devono immediatamente aggiornare l'archivio.

Creare un backup dell'archivio

E' consigliato effettuare spesso dei backup dell'archivio, che possono essere ripristinati in caso di danneggiamento o qualsiasi altra necessità.
Xautomation si connette al database xautoex, che contiene definizioni, informazioni di messa in onda, informazioni sulle schedulazioni settimanali e altri dati importanti necessari al funzionamento dell'archivio in uso.

Da impostazione predefinita, Xautomation effettua un backup dell'archivio alle ore 01.00.10. Questo settaggio può essere modificato da Modifica > Impostazioni, scheda Avvio, dall'opzione Esegui backup archivio alle ore. E' possibile indicare anche se eseguire un backup del database SQL in uso o una ricarica del palinsesto e a quale ora effettuare le operazione.

Per eseguire automaticamente il backup dell'archivio in qualsiasi momento:

  1. Nella barra dei menu e fare clic su File > Crea backup.
  2. Fare clic su OK per confermare l'operazione. Mettere la spunta sull'opzione Effettua backup del database SQL per effettuare anche il backup del database.
    Ogni backup dell'archivio viene salvato nella cartella bak della directory locale di installazione di Xautomation.
    Tutti i backup sono pacchetti .zip contenenti i file dell'archivio, da sostituire in caso di necessità nella cartella lib. Ogni pacchetto viene nominato automaticamente utilizzando il nome dell'archivio e la data e ora di creazione del backup.



IMPORTANTE:
Le operazioni di backup dell'archivio non copiano i file audio caricati e contenuti all'interno dell'unità Z:. Si raccomanda quindi di effettuare periodicamente i backup di tutti i file audio.

E' possibile infine utilizzare l'utility SQLConfig presente nel percorso di installazione di Xautomation per salvare un backup del database manualmente:

  1. Avviare SQLConfig dal percorso di installazione.
  2. Fare clic sul pulsante Aggiorna per aggiornare l'elenco dei database contenuti nel server SQL predefinito.
  3. Assicurarsi di aver selezionato dal menu a tendina il database xautoex.
  4. Fare clic sulla scheda Backup|Restore.
  5. Fare clic sul pulsante Backup e attendere la fine della procedura.
    I backup del database vengono salvati nella cartella predefinita C:\SQLXDEVEL\BAK. Anche in questo caso, i backup vengono salvati con il nome del database (xautoex) seguito da data e ora di creazione del backup.
    I file sono in formato .bak, formato gestibile da SQLConfig o altre utility di terze parte per il ripristino dei database SQL.

Per maggiori informazioni sul ripristino dei backup consultare il capitolo Ripristinare un backup di archivio e database SQL.

(0 voto/i)
Utile
Non è utile

Commenti (0)